Tuesday, May 10, 2011

GNS3 VLAN VTP

the configuration
#SW0
interface FastEthernet1/0
switchport mode trunk
interface FastEthernet1/1
switchport mode trunk
interface FastEthernet1/2
switchport mode trunk
interface FastEthernet1/15
switchport mode trunk

or
interface range fastethernet 1/0 - 2
switchport mode trunk
at the exec-mode #
vlan database
vtp domain gns3cisco
vlan 10 name accounting
vlan 20 name markting
vlan 30 name operations
vlan 100 name administration
apply
#sw1
interface FastEthernet1/0
switchport mode trunk


vlan database
vtp client


interface range fastethernet 1/10 - 12
switchport mode access
switchport access vlan 100

#sw2
interface FastEthernet1/0
switchport mode trunk


vlan database
vtp client


interface FastEthernet1/10
switchport mode access
switchport access vlan 10
interface FastEthernet1/11
switchport mode access
switchport access vlan 20
interface FastEthernet1/12
switchport mode access
switchport access vlan 30

#sw3
interface FastEthernet1/0
switchport mode trunk


vlan database
vtp client


interface FastEthernet1/10
switchport mode access
switchport access vlan 10
interface FastEthernet1/11
switchport mode access
switchport access vlan 20
interface FastEthernet1/12
switchport mode access
switchport access vlan 30
router 1
R1(config)#interface fastEthernet 0/0
R1(config-if)#no shut
R1(config-if)#interface fastEthernet 0/0.10
R1(config-subif)#encapsulation dot1Q 10
R1(config-subif)#ip address 192.168.10.1 255.255.255.0
R1(config-subif)#no shut

R1(config-if)#interface fastEthernet 0/0.20
R1(config-subif)#encapsulation dot1Q 20
R1(config-subif)#ip address 192.168.20.1 255.255.255.0
R1(config-subif)#no shut

R1(config-if)#interface fastEthernet 0/0.30
R1(config-subif)#encapsulation dot1Q 30
R1(config-subif)#ip address 192.168.30.1 255.255.255.0
R1(config-subif)#no shut

R1(config-if)#interface fastEthernet 0/0.100
R1(config-subif)#encapsulation dot1Q 100
R1(config-subif)#ip address 192.168.100.1 255.255.255.0
R1(config-subif)#no shut


download this topology copy VPcs file : vlansto to the VPCs directory and load it
download VPCs

2 comments:

  1. Doesn't work, following error arises

    Dynagen management console for Dynamips (adapted for GNS3)
    Copyright (c) 2008-2010 GNS3 Project

    => Local IOS image H:\network\XMT\CISCO\IOS\c3700\c3745-adventerprisek9-mz.123-26_[www.CareerCert.info].bin.unpacked cannot be found for hypervisor 127.0.0.1:7201, use image D:\GNS3\working ios\c3745-adventerprisek9-mz.123-26_[www.CareerCert.info].bin instead
    *** Warning: received dynamips server error:
    203-Bad number of parameters (1 with min/max=2/2)
    *** Warning: received dynamips server error:
    203-Bad number of parameters (1 with min/max=2/2)
    *** Warning: received dynamips server error:
    203-Bad number of parameters (1 with min/max=2/2)
    *** Warning: received dynamips server error:
    203-Bad number of parameters (1 with min/max=2/2)
    *** Warning: Connecting R1 f0/0 to SW0 f1/15 resulted in:
    nonexistent device SW0

    *** Error: errors during loading of the topology file, please correct them

    ReplyDelete
  2. Local IOS image H:\network\XMT\CISCO\IOS\c3700\c3745-adventerprisek9-mz.123-26_[www.CareerCert.info].bin.unpacked cannot be found for hypervisor
    change the image location with your image location
    please download the IOS image c3745 i always use this IOS

    ReplyDelete